Konfigurasi NAT pada Router 2621xm

Studi Kasus : Sebuah perusahaan yang memiliki sejumlah ip address public yang diberikan oleh ISP (Internet Service Provider). karena perkembangan yang signifikan, maka IP public tersebut tidak mencukupi untuk memenuhi kebutuhan perusahaan tersebut.  oleh karena itu manager IT diperusahaan tersebut, menganbil keputusan untuk merancang NAT (Network Address Translation) pada perusahaan yang tersebut sebagai solusi dari kekurangan ip public tersebut.

Topologi yang akan digunakan adalah sebagai berikut :

Topologi NAT

Terdapat 3 buah router yang akan digunakan pada tutorial kali ini, diantaranya Router Jakarta, ISP dan San Francisco. clock rate terdapat pada ISP.

1. Router Jakarta :

Network IP Private : 10.10.10.0/24

Gateway : 10.10.10.100/24

IP address Serial 0/0 (DTE) : 200.2.2.17/32

Network IP Public : 199.99.9.32/27

2. Router ISP :

IP address Serial 0/0 (DCE) : 200.2.2.18/32

IP address IP addressSerial 0/1 (DCE) : 200.2.2.22/32

3. Router San Francisco :

Network IP Private : 192.168.17.0/24

Gateway : 192.168.17.100/24

IP address Serial 0/0 (DTE) : 200.2.2.21/32

Network IP Public : 199.99.9.64/27

Server : Web Server dan DNS Server

IP add Web Server  : 192.168.17.252 di tranlasikan menjadi 199.99.9.65

IP add DNS Server : 192.168.17.253 di translasikan menjadi 199.99.9.64

Untuk melakukan konfigurasi ini dibutuhkan aplikasi simulasi, aplikasi simulasi yang saya gunakan pada percobaan kali ini adalah Packet Tracer 4 atau 5.

oh iya, untuk melakukan konfigurasi ini tentunya kita membutuhkan routing protokol, routing protokol yang digunakan adalah routing protokol styatic routing dan dynamic routing dengan menggunakan RIP version 2.

Konfigurasi router Jakarta :

Router>en
Router#config t
Router(config)#hostname Jakarta –> memberikan hostname pada router

Jakarta(config)#int f0/0 –> masuk kedalam interface fastethernet (Gateway Jakarta)
Jakarta(config-if)#ip add 10.10.10.100 255.255.255.0 –> memberikan IP Address pada interface F0/0
Jakarta(config-if)#no shut –> menghidupkan interface f0/0

Jakarta(config-if)#int s0/0 –> masuk kedalam interface serial 0/0
Jakarta(config-if)#ip add 200.2.2.17 255.255.255.252 –> memberikan ip address serial s0/0 pada router di jakarta
Jakarta(config-if)#no shut

Jakarta(config-if)#exit
Jakarta(config)#ip route 0.0.0.0 0.0.0.0 200.2.2.18 –> memberikan default route pada static routing, yang berarti semua tujuan koneksi yang dilakukan pada jaringan LAN di jakarta, akan diarahkan terlebih dahulu ke 200.2.2.18 (IP Address ISP)

Jakarta(config)#ip nat pool public-access 199.99.9.40 199.99.9.62 netmask 255.255.255.224 –> membuat sebuah pool (kumpulan range IP Address public dari 199.99.9.40 – 199.99.9.62) yang akan digunakan oleh jaringan lokal dengan nama public-access, nama ini dapat dirubah sesuai kebutuhan.

Jakarta(config)#access-list 1 permit 10.10.10.0 0.0.0.255 –> merupakan aturan access list, permit merupakan melakukan forward pada network 10.10.10.0 dan 1 merupakan rules yang digunakan adalah standart. 0.0.0.255 merupakan wildcard dari subnet 255.255.255.0. yang didapatkan dari 255.255.255.255 – 255.255.255.0.

Jakarta(config)#ip nat inside source list 1 pool public-access –> meruoakan dynamic NAT yang ip publiknya diambil dari pool public access

Jakarta(config)#int f0/0
Jakarta(config-if)#ip nat inside –> mendefinisikan bahwa interface f0/0 terdapat NAT inside, yang dimasukan.

Jakarta(config-if)#int s0/0
Jakarta(config-if)#ip nat outside mendefinisikan bahwa interface f0/0 terdapat NAT outside, yang dikeluarkan.

Jakarta(config-if)#router rip –> konfigurasi router rip
Jakarta(config-if)# version 2 –> mendefinisikan router rip version 2
Jakarta(config-if)# network 10.10.10.0 –> medefinisi network yang terhubung langsung dari router Jakarta
Jakarta(config-if)# network 200.2.2.16 –> medefinisi network yang terhubung langsung dari router Jakarta

Jakarta(config-if)#end
Jakarta#cop run start
Jakarta#sh ip route

Konfigurasi San Francisco

Router>en
Router#config t
Router(config)#hostname Sanfrancisco

Sanfrancisco(config)#int f0/0
Sanfrancisco(config-if)#ip add 192.168.17.100 255.255.255.0
Sanfrancisco(config-if)#no shut

Sanfrancisco(config-if)#int s0/0
Sanfrancisco(config-if)#ip add 200.2.2.21 255.255.255.252
Sanfrancisco(config-if)#no shut

Sanfrancisco(config)#ip route 0.0.0.0 0.0.0.0 200.2.2.22

Static NAT dengan IP Address
Sanfrancisco(config)#ip nat inside source static 192.168.17.252  199.99.9.66 –> mendefinisikan bahwa ip address 192.168.17.252 akan ditranslasikan menjadi 199.99.9.66

Sanfrancisco(config)#ip nat inside source static 192.168.17.253 199.99.9.65 –> konfigurasi NAT secara Static

Sanfrancisco(config)#access-list 1 permit 192.168.17.0 0.0.0.255

Sanfrancisco(config)#int f0/0
Sanfrancisco(config-if)#ip nat inside

Sanfrancisco(config-if)#int s0/0
Sanfrancisco(config-if)#ip nat outside

Sanfrancisco(config)#router rip
Sanfrancisco(config)# version 2
Sanfrancisco(config)# network 192.168.17.0
Sanfrancisco(config)# network 200.2.2.20

Sanfrancisco(config-if)#end
Sanfrancisco#cop run start
Sanfrancisco#sh ip route
Sanfrancisco#sh ip nat translations


ISP
Router>en
Router#config t
Router(config)#hostname ISP

ISP(config)#int loopback 0 –> mendefinisikan IP loopback
ISP(config-if)#ip add 172.16.1.1 255.255.255.255
ISP(config-if)#no shut
ISP(config-if)#exit

ISP(config)#int s0/0
ISP(config-if)#ip add 200.2.2.18 255.255.255.252
ISP(config-if)#clock rate 64000 –> Clock rate yang digunakan, 64000 bit/s
ISP(config-if)#no shut

ISP(config-if)#int s0/1
ISP(config-if)#ip add 200.2.2.22 255.255.255.252
ISP(config-if)#clock rate 64000
ISP(config-if)#no shut

ISP(config)#router rip
ISP(config)# version 2
ISP(config)# network 200.2.2.16
ISP(config)# network 200.2.2.20

ISP(config-if)#exit
ISP(config)#ip route 199.99.9.32 255.255.255.224 200.2.2.17 –> static routing, static routing memiliki format : [destination network] [destination network netmask]  [next hop]
ISP(config)#ip route 199.99.9.64 255.255.255.224 200.2.2.21 –> static routing

ISP(config)#end
ISP#cop run start
ISP#sh ip route

Setelah selesai melakukan konfigurasi, kita akan melakukan uji koneksi dengan melakukan ping :

Dari pc jakarta ping ke pc San Francisco

PC>ping 192.168.17.252

Pinging 192.168.17.252 with 32 bytes of data:

Reply from 192.168.17.252: bytes=32 time=188ms TTL=125
Reply from 192.168.17.252: bytes=32 time=157ms TTL=125
Reply from 192.168.17.252: bytes=32 time=141ms TTL=125
Reply from 192.168.17.252: bytes=32 time=187ms TTL=125

Ping statistics for 192.168.17.252:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 141ms, Maximum = 188ms, Average = 168ms

Dari pc San Francisco ke pc Jakarta

SERVER>ping 10.10.10.1

Pinging 10.10.10.1 with 32 bytes of data:

Reply from 199.99.9.40: bytes=32 time=219ms TTL=125
Reply from 199.99.9.40: bytes=32 time=188ms TTL=125
Reply from 199.99.9.40: bytes=32 time=171ms TTL=125
Reply from 199.99.9.40: bytes=32 time=188ms TTL=125

Ping statistics for 10.10.10.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 171ms, Maximum = 219ms, Average = 191ms

Melihat tabel NAT yang dibuat oleh router.

Router Jakarta

Jakarta#show ip nat translations
Pro      Inside global       Inside local         Outside local         Outside global
—        199.99.9.40        10.10.10.1            —                              —
tabel diatas equivalen dengan ip add 10.10.10.1 akan di translasikan menjadi 199.99.9.40 jika ia ingin melakukan koneksi dengan wan atai internet.

San Francisco

Sanfrancisco#show ip nat translations
Pro    Inside global       Inside local               Outside local     Outside global
—      199.99.9.65         192.168.17.253       —                          —
—      199.99.9.66         192.168.17.252       —                          —

semoga ilmu ini bermanfaat…^_^

8 responses to this post.

  1. Posted by Mys on May 28, 2009 at 4:23 am

    Thx,,,sangat membantu

    Reply

  2. wew keren…..
    Tanya donk klo buat PAT gmn ya….
    maklum masih belajar😀

    Reply

    • Posted by Putra_tanjung_Pinank on June 3, 2009 at 10:52 am

      ow untuk PAT, konfigurasinya cukup sederhana, akan ada konfigurasi khusus PAT yaang saya akan buat…jadi bersabar ya,,

      Reply

  3. Posted by rubi on May 29, 2010 at 8:58 am

    Boleh konsultasi

    Reply

  4. Posted by indriani on June 18, 2010 at 6:29 pm

    ap perbedaan network id dan host id..????

    Reply

    • Posted by Putra_tanjung_Pinank on June 20, 2010 at 1:12 pm

      IP address terbagi 2 komponen : Network dan Host ID.
      sebagai analogi Network ID merupakan nama jalan dan Host ID merupakan no rumah kita.
      Letak Network dan Host ID berbeda2 disetiap kelas IP Address, berikut pembahasannya:

      pada kelas A network ID berada pada Oktet pertama
      pada kelas B network ID berada pada Oktet kedua
      pada kelas C network ID berada pada Oktet ketiga

      dapat kita lihat, bahwa kelas A lebih sedikit Network tetapi memliki banyak Host dan sebaliknya kelas C
      memiliki banyak Netwok tetapi lebih sedikit Hostnya.

      semoga membantu.

      Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: